FreeVPS Directory & Discussion
Setting-up Openvpn on Webmin ( Centos 6 ) - Printable Version

+- FreeVPS Directory & Discussion (https://freevps.us)
+-- Forum: Free VPS Discussion (https://freevps.us/forum-1.html)
+--- Forum: Tutorials (https://freevps.us/forum-7.html)
+--- Thread: Setting-up Openvpn on Webmin ( Centos 6 ) (/thread-9163.html)

Pages: 1 2 3 4 5 6 7 8 9


RE: Setting-up Openvpn on Webmin ( Centos 6 ) - denom - 2013-05-17

Bluehawk pm me too.. i need to setup vpn or just pm me on facebook


RE: Setting-up Openvpn on Webmin ( Centos 6 ) - bluehawk - 2013-05-17

(2013-05-17, 5:15:27 pm)denom Wrote:  Bluehawk pm me too.. i need to setup vpn or just pm me on facebook

What you've gave me was a centOs 5.9, lol ,.
It's a vps from vmware. Even I can't managed to set up there.
Maybe because it's a cloud server, or it has strict firewall just like upcloud.


RE: Setting-up Openvpn on Webmin ( Centos 6 ) - bluehawk - 2013-05-18

I just found out how to set it up on vmware vps's . Smile
Finally!

How? First thing to do is to disable the " Public Cloud Firewall " located here: https://vcloudservice.vmware.com/cloud/network/public/beta

Then command :

Terminal

[root@bluehawk ~]# ifconfig

Find the inet addr:192.168.x.x
That will be the address you will put on iptable rules.

Then on your vpn server conf on the " Local host name or IP address "
Put ALL instead of your public ip.
Then restart openvpn. It should be working now.
Maybe I'll write about it on my blog later. Goodluck.

[Image: screenshot_76.png]


RE: Setting-up Openvpn on Webmin ( Centos 6 ) - thedarefate - 2013-06-06

Oh well, just if I follow this article earlier
I may not screwed up my brand new VPS 25
right now Im stuck middle of somewhere, always getting no route to host message on client side, going to re-start from scrath again by following this tutorial, I will try this tut tomorrow


RE: Setting-up Openvpn on Webmin ( Centos 6 ) - bluehawk - 2013-06-07

(2013-06-06, 11:56:19 pm)thedarefate Wrote:  Oh well, just if I follow this article earlier
I may not screwed up my brand new VPS 25
right now Im stuck middle of somewhere, always getting no route to host message on client side, going to re-start from scrath again by following this tutorial, I will try this tut tomorrow

no route to host? maybe you forgot to put the ip address on the client side, check it, but you've already install properly the openvpn right? And it successfully start? If yes, you just missed the ip for sure.

Updated: Added some clarifications/additional instructions and removed unnecessary steps. ( The one I think was not needed to do anymore )


RE: Setting-up Openvpn on Webmin ( Centos 6 ) - thedarefate - 2013-06-07

@bluehawk013
already added the IP, I think there is something wrong on server side
First I installed openvpn-2.3 but cant start because of its PAM plugin,
then I downgrade it to 2.2 version, successfully started without any errors and just cant connect to the server, I think I screwed the configuration somewhere.
Im just going to reinstall my OS anyway :p


RE: Setting-up Openvpn on Webmin ( Centos 6 ) - thedarefate - 2013-06-16

Dear bluehawk013
I followed yours tutorial and I successfully connected to the server
but on client side I cant connect to the internet
and I dont see any error on openvpn.log
Im on KVM btw
thanks in advance


RE: Setting-up Openvpn on Webmin ( Centos 6 ) - 0oDeSm0nDo0 - 2013-06-16

^ u may not hav configured ur iptable properly. change ur sysctl.conf to enable ipv4 routing and restart ur sysctl via sysctl -p .. and also, there is a small thing of iptable routing in kvm vps ... if possible, paste prevoius wrking iptable configs into ur kvm vps,otherwise, try to open ports manually via issuing command on specific port


RE: Setting-up Openvpn on Webmin ( Centos 6 ) - bluehawk - 2013-06-16

(2013-06-16, 12:48:44 am)thedarefate Wrote:  Dear bluehawk013
I followed yours tutorial and I successfully connected to the server
but on client side I cant connect to the internet
and I dont see any error on openvpn.log
Im on KVM btw
thanks in advance

You will not see it on openvpn log.
It's on your routing. Check your iptables, if it was correctly set up.


RE: Setting-up Openvpn on Webmin ( Centos 6 ) - thedarefate - 2013-06-16

Problem solved
I forget the routing things on my iptables
Thanks for helping me
+1 added to bluehawk013