[SOLVED] keeping xrdp and lxde desktop opened even when session is closed ?
#1
So, I'm currently trying to run sa-mp server through debian lxde desktop so I could have better management over the server instead of just using the terminal only.
I've been wondering, Is it possible to keep xrdp and lxde desktop opened even when I close them ?
[Image: vkhbt94.jpg]
[Image: img.php?userid=12078]
#2
(2016-01-18, 12:47:17 am)Co0oL Wrote:  I've been wondering, Is it possible to keep xrdp and lxde desktop opened even when I close them ?

Yes it is. Those sessions will be persistent.
BTW you can find tutorials I and others did here for XRDP.
#3
(2016-01-18, 3:33:00 am)gooliver Wrote:  Yes it is. Those sessions will be persistent.
BTW you can find tutorials I and others did here for XRDP.

I found the XRDP tutorial but that didn't answer my question :V
[Image: vkhbt94.jpg]
[Image: img.php?userid=12078]
#4
then i think it would help us answer if you please take your time explain your question further.. You want to access your LXDE session over xRDP and there run some (samp) programs and you want them to keep running and want the LXDE session to remain active even when you are not connected to it. If that is what you are trying to achieve then what is it you are doing right now to achieve that and what are the problems you are facing during that ?
Many thanks to Freevps, Chris (cw1998), The Guy( ID 4810), optimus, GHP and the other  staff members.
#5
(2016-01-18, 5:37:22 am)rudra Wrote:  then i think it would help us answer if you please take your time explain your question further.. You want to access your LXDE session over xRDP and there run some (samp) programs and you want them to keep running and want the LXDE session to remain active even when you are not connected to it. If that is what you are trying to achieve then what is it you are doing right now to achieve that and what are the problems you are facing during that ?

Exactly.
What is happening wrong to me atm that after couple of hours the LXDE desktop is closed.
[Image: vkhbt94.jpg]
[Image: img.php?userid=12078]
#6
What do you mean by closed ? Do you keep your xRDP open on your own computer and it gets disconnected after few hours or do you mean when you try to reconnect to your old session on the same port (assuming 5910 or something) using mstsc.msc or another rdp client, you get an error similar to a non-existant session ?

May I ask what did you put in your /etc/xrdp/xrdp.ini ?

Last but not the least, I am really at loss as to what more could you do with SAMP server from graphical mode, that you can not from terminal !!

Re - sorry if I appear to be a bit slow or you get the idea that I am treating you like a schoolkid. Clear explanation of the problem at hand helps people like us who are not omniscient (like what they want to accomplish, what they did so far to that end and the exact reports , his conclusions so far and why he reached to those conclusions.)
Many thanks to Freevps, Chris (cw1998), The Guy( ID 4810), optimus, GHP and the other  staff members.
#7
(2016-01-18, 8:46:40 am)rudra Wrote:  What do you mean by closed ? Do you keep your xRDP open on your own computer and it gets disconnected after few hours or do you mean when you try to reconnect to your old session on the same port (assuming 5910 or something) using mstsc.msc or another rdp client, you get an error similar to a non-existant session ?

May I ask what did you put in your /etc/xrdp/xrdp.ini ?

Last but not the least, I am really at loss as to what more could you do with SAMP server from graphical mode, that you can not from terminal !!

Re - sorry if I appear to be a bit slow or you get the idea that I am treating you like a schoolkid. Clear explanation of the problem at hand helps people like us who are not omniscient (like what they want to accomplish, what they did so far to that end and the exact reports , his conclusions so far and why he reached to those conclusions.)

Well, I'm thinking of managing more than one server and creating a tutorial about creating sa-mp server on linux but this time using graphical GUI instead of just terminal, Some people find terminal killing hard to use and they suffer just to connect to it.

I didn't put anything in /etc/xrdp/xrdp.ini
(here's how it looks)
Code:
[globals]
bitmap_cache=yes
bitmap_compression=yes
port=3389
crypt_level=low
channel_code=1

[xrdp1]
name=sesman-Xvnc
lib=libvnc.so
username=ask
password=ask
ip=127.0.0.1
port=-1

[xrdp2]
name=console
lib=libvnc.so
ip=127.0.0.1
port=5900
username=na
password=ask

[xrdp3]
name=vnc-any
lib=libvnc.so
ip=ask
port=ask5900
username=na
password=ask

[xrdp4]
name=sesman-any
lib=libvnc.so
ip=ask
port=-1
username=ask
password=ask

[xrdp5]
name=rdp-any
lib=librdp.so
ip=ask
port=ask3389

[xrdp6]
name=sesman-X11rdp
lib=libxup.so
username=ask
password=ask
ip=127.0.0.1
port=-1

Also, I meant keeping the XRDP/LXDE session even after I disconnect/close RDP on my person PC.

The problem for me is, I connect to session > Start SA-MP server > disconnect from session.
The server stays online for a couple of hours (a friend reported that it stays exactly 1 hour after my disconnect). when I reconnect to the server again, There is nothing running.
[Image: vkhbt94.jpg]
[Image: img.php?userid=12078]
#8
change port setting under [xrdp1]

make it
port=ask5910

now save it and restart xrdp by "service xrdp restart".

then start a session using windows mstsc.msc client. enter port as -1 for the first time. It takes 5910 as default to start. you will be able to see it at the connection progress dialogue. When the desktop loads, you start anything do whatever you want and then disconnect. from now on, whenever you reconnect, you can just enter your account id and pass to login and resume (assuming the default port it started on was 5910 for the first time. or change the setting accordingly).


i hope your samp settings and cron job or whatever the process you are using to monitor the servers are set up properly. Hope it help.
Many thanks to Freevps, Chris (cw1998), The Guy( ID 4810), optimus, GHP and the other  staff members.
#9
(2016-01-19, 6:59:42 am)rudra Wrote:  change port setting under [xrdp1]

make it
port=ask5910


then start a session using windows mstsc.msc client. enter port as -1 for the first time. It takes 5910 as default to start. you will be able to see it at the connection progress dialogue. When the desktop loads, you start anything do whatever you want and then disconnect. from now on, whenever you reconnect, you can just enter your account id and pass to login and resume (assuming the default port it started on was 5910 for the first time. or change the setting accordingly).


i hope your samp settings and cron job or whatever the process you are using to monitor the servers are set up properly. Hope it help.
The first time I did what you said in this post, It showed problem in connecting to the port.
I went to eat something and got back and tried again and it worked (restart xrdp service when I came back tho).
The server is working just fine and the server is still running, I want to give it few hours thought to test it.
Would be thankful if HR gives this couple of hours for testing, Thanks again for the guide at rudra.
I've seen this guide on over 5 sites online but they all told me to edit the port into different things and I always found a dead end eventually

Edit: So, It's working so far for over 12 hours now, Thanks for the suggestions.
[Image: vkhbt94.jpg]
[Image: img.php?userid=12078]
#10
I should have told you to restart after the change. Actually if you think how services work, it is pretty obvious.
some things become so much like first principles, that we often forget to mention those ! sorry for that Tounge

I am happy to know that it is working . Where are my sweets and reps Tounge .. joking
Many thanks to Freevps, Chris (cw1998), The Guy( ID 4810), optimus, GHP and the other  staff members.




Users browsing this thread: 1 Guest(s)