[SOLVED] VestaCP bug - how to create MX record for Yandex/Zoho?
Am wondering whether anyone has found a simple fix for this bug?  I'm trying to set up e-mail with Yandex/Zoho in VestaCP.  Requirement of course is to set up an MX record - which comes up with a bug.  This seems to be a known bug #283, but doesn't look as though a simple solution has been found.  Does anyone know of a workaround for the bug?  Looks as though VestaCP is looking for an IP for the value - like it doesn't understand to use the mx.zoho.com as the value.

Spoiler: show
[Image: c8OjL0f.png]
This is a pullrequest that fixes that as far as I know.

Maybe you can just merge it on your local repo or something.
I did try the solution below:

Spoiler: show
[Image: P0qlUF7.png]

Basically it amounts to adding this line:

is_domain_format_valid "${1::-1}" 'mx_record'

I fixed it, checked and rechecked - rebooted.  And it didn't make a difference - so far anyway.  Same error is coming up.

Note later: Just realized I was supposed to replace the line above it with the line below it. For MX and NS records. So went in to delete the lines that should have been overwritten. Then rebooted. And it works!

Users browsing this thread: 1 Guest(s)