High config, still website high cpu uses
#11
(2016-08-31, 6:31:12 am)Conan Wrote:  Would you like to try setting more workers for php-fpm?
That would spread the load on more processes.
The config is on /etc/php-fpm.d/www.conf on centos systems afaik.

Try increasing pm.max_children, pm.max_spare_servers, pm.max_requests.

Also use varnish in front of nginx? You have quite a lot of ram. This would help with cpu usage I think.

Use also the latest version of php-fpm. (Custom compile it if it's not available in centos5)

If you have reddit, pm me. I'm /u/1Conan
I will be able to help during some of my classes and breaks.

Yes, I've the updated version and tried to change the config. changed rlimit_files = 4096 too

Here is the file:
Code:
; Start a new pool named 'www'.
[www]

; The address on which to accept FastCGI requests.
; Valid syntaxes are:
;   'ip.add.re.ss:port'    - to listen on a TCP socket to a specific address on
;                            a specific port;
;   'port'                 - to listen on a TCP socket to all addresses on a
;                            specific port;
;   '/path/to/unix/socket' - to listen on a unix socket.
; Note: This value is mandatory.
listen = 127.0.0.1:9000

; Set listen(2) backlog. A value of '-1' means unlimited.
; Default Value: -1
;listen.backlog = -1

; List of ipv4 addresses of FastCGI clients which are allowed to connect.
; Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the original
; PHP FCGI (5.2.2+). Makes sense only with a tcp listening socket. Each address
; must be separated by a comma. If this value is left blank, connections will be
; accepted from any ip address.
; Default Value: any
listen.allowed_clients = 127.0.0.1

; Set permissions for unix socket, if one is used. In Linux, read/write
; permissions must be set in order to allow connections from a web server. Many
; BSD-derived systems allow connections regardless of permissions.
; Default Values: user and group are set as the running user
;                 mode is set to 0666
;listen.owner = nobody
;listen.group = nobody
;listen.mode = 0666

; Unix user/group of processes
; Note: The user is mandatory. If the group is not set, the default user's group
;       will be used.
; RPM: apache Choosed to be able to access some dir as httpd
user = php
; RPM: Keep a group allowed to write in log dir.
group = php

; Choose how the process manager will control the number of child processes.
; Possible Values:
;   static  - a fixed number (pm.max_children) of child processes;
;   dynamic - the number of child processes are set dynamically based on the
;             following directives:
;             pm.max_children      - the maximum number of children that can
;                                    be alive at the same time.
;             pm.start_servers     - the number of children created on startup.
;             pm.min_spare_servers - the minimum number of children in 'idle'
;                                    state (waiting to process). If the number
;                                    of 'idle' processes is less than this
;                                    number then some children will be created.
;             pm.max_spare_servers - the maximum number of children in 'idle'
;                                    state (waiting to process). If the number
;                                    of 'idle' processes is greater than this
;                                    number then some children will be killed.
; Note: This value is mandatory.
pm = ondemand
pm.process_idle_timeout = 3s

; The number of child processes to be created when pm is set to 'static' and the
; maximum number of child processes to be created when pm is set to 'dynamic'.
; This value sets the limit on the number of simultaneous requests that will be
; served. Equivalent to the ApacheMaxClients directive with mpm_prefork.
; Equivalent to the PHP_FCGI_CHILDREN environment variable in the original PHP
; CGI.
; Note: Used when pm is set to either 'static' or 'dynamic'
; Note: This value is mandatory.
pm.max_children = 5

; The number of child processes created on startup.
; Note: Used only when pm is set to 'dynamic'
; Default Value: min_spare_servers + (max_spare_servers - min_spare_servers) / 2
pm.start_servers = 1

; The desired minimum number of idle server processes.
; Note: Used only when pm is set to 'dynamic'
; Note: Mandatory when pm is set to 'dynamic'
pm.min_spare_servers = 1

; The desired maximum number of idle server processes.
; Note: Used only when pm is set to 'dynamic'
; Note: Mandatory when pm is set to 'dynamic'
pm.max_spare_servers = 1

; The number of requests each child process should execute before respawning.
; This can be useful to work around memory leaks in 3rd party libraries. For
; endless request processing specify '0'. Equivalent to PHP_FCGI_MAX_REQUESTS.
; Default Value: 0
pm.max_requests = 500

; The URI to view the FPM status page. If this value is not set, no URI will be
; recognized as a status page. By default, the status page shows the following
; information:
;   accepted conn    - the number of request accepted by the pool;
;   pool             - the name of the pool;
;   process manager  - static or dynamic;
;   idle processes   - the number of idle processes;
;   active processes - the number of active processes;
;   total processes  - the number of idle + active processes.
; The values of 'idle processes', 'active processes' and 'total processes' are
; updated each second. The value of 'accepted conn' is updated in real time.
; Example output:
;   accepted conn:   12073
;   pool:             www
;   process manager:  static
;   idle processes:   35
;   active processes: 65
;   total processes:  100
; By default the status page output is formatted as text/plain. Passing either
; 'html' or 'json' as a query string will return the corresponding output
; syntax. Example:
;   http://www.foo.bar/status
;   http://www.foo.bar/status?json
;   http://www.foo.bar/status?html
; Note: The value must start with a leading slash (/). The value can be
;       anything, but it may not be a good idea to use the .php extension or it
;       may conflict with a real PHP file.
; Default Value: not set
;pm.status_path = /status

; The ping URI to call the monitoring page of FPM. If this value is not set, no
; URI will be recognized as a ping page. This could be used to test from outside
; that FPM is alive and responding, or to
; - create a graph of FPM availability (rrd or such);
; - remove a server from a group if it is not responding (load balancing);
; - trigger alerts for the operating team (24/7).
; Note: The value must start with a leading slash (/). The value can be
;       anything, but it may not be a good idea to use the .php extension or it
;       may conflict with a real PHP file.
; Default Value: not set
;ping.path = /ping

; This directive may be used to customize the response of a ping request. The
; response is formatted as text/plain with a 200 response code.
; Default Value: pong
;ping.response = pong

; The timeout for serving a single request after which the worker process will
; be killed. This option should be used when the 'max_execution_time' ini option
; does not stop script execution for some reason. A value of '0' means 'off'.
; Available units: s(econds)(default), m(inutes), h(ours), or d(ays)
; Default Value: 0
;request_terminate_timeout = 0

; The timeout for serving a single request after which a PHP backtrace will be
; dumped to the 'slowlog' file. A value of '0s' means 'off'.
; Available units: s(econds)(default), m(inutes), h(ours), or d(ays)
; Default Value: 0
;request_slowlog_timeout = 0

; The log file for slow requests
; Default Value: /var/log/php-fpm.log.slow
;slowlog = /var/log/php-fpm.log.slow

; Set open file descriptor rlimit.
; Default Value: system defined value
;rlimit_files = 1024

; Set max core size rlimit.
; Possible Values: 'unlimited' or an integer greater or equal to 0
; Default Value: system defined value
;rlimit_core = 0

; Chroot to this directory at the start. This value must be defined as an
; absolute path. When this value is not set, chroot is not used.
; Note: chrooting is a great security feature and should be used whenever
;       possible. However, all PHP paths will be relative to the chroot
;       (error_log, sessions.save_path, ...).
; Default Value: not set
;chroot =

; Chdir to this directory at the start. This value must be an absolute path.
; Default Value: current directory or / when chroot
;chdir = /var/www

; Redirect worker stdout and stderr into main error log. If not set, stdout and
; stderr will be redirected to /dev/null according to FastCGI specs.
; Default Value: no
;catch_workers_output = yes

; Pass environment variables like LD_LIBRARY_PATH. All  are taken from
; the current environment.
; Default Value: clean env
;env[HOSTNAME] = nl
;env[PATH] = /usr/local/bin:/usr/bin:/bin
;env[TMP] = /tmp
;env[TMPDIR] = /tmp
;env[TEMP] = /tmp

; Additional php.ini defines, specific to this pool of workers. These settings
; overwrite the values previously defined in the php.ini. The directives are the
; same as the PHP SAPI:
;   php_value/php_flag             - you can set classic ini defines which can
;                                    be overwritten from PHP call 'ini_set'.
;   php_admin_value/php_admin_flag - these directives won't be overwritten by
;                                     PHP call 'ini_set'
; For php_*flag, valid values are on, off, 1, 0, true, false, yes or no.

; Defining 'extension' will load the corresponding shared extension from
; extension_dir. Defining 'disable_functions' or 'disable_classes' will not
; overwrite previously defined php.ini values, but will append the new value
; instead.

; Default Value: nothing is defined by default except the values in php.ini and
;                specified at startup with the -d argument
;php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f www@my.domain.com
;php_flag[display_errors] = off
php_admin_value[error_log] = /var/log/php-fpm/www-error.log
php_admin_flag[log_errors] = on
;php_admin_value[memory_limit] = 32M
php_admin_value[upload_max_filesize] = 32M
#12
I have two configurations for you to try to reduce the cpu usage.

First, you should use dynamic as your pm since afaik, constantly forking processes use quite a bit of the cpu. (Also increasing workers etc etc)
Code:
[www]
listen = 127.0.0.1:9000
listen.allowed_clients = 127.0.0.1
user = php
group = php
pm = dynamic
pm.process_idle_timeout = 3s
pm.max_children = 8
pm.start_servers = 2
pm.min_spare_servers = 2
pm.max_spare_servers = 4
pm.max_requests = 500

Second, this is set to static. Use only if you have quite a lot of free ram left. (A few gbs)
Code:
[www]
listen = 127.0.0.1:9000
listen.allowed_clients = 127.0.0.1
user = php
group = php
pm = static
pm.process_idle_timeout = 3s
pm.max_children = 8
pm.start_servers = 8

I still highly recommend Varnish if you use a heavy php site that doesn't update like every minute.
#13
(2016-08-31, 10:17:22 pm)Conan Wrote:  I have two configurations for you to try to reduce the cpu usage.

First, you should use dynamic as your pm since afaik, constantly forking processes use quite a bit of the cpu. (Also increasing workers etc etc)
Code:
[www]
listen = 127.0.0.1:9000
listen.allowed_clients = 127.0.0.1
user = php
group = php
pm = dynamic
pm.process_idle_timeout = 3s
pm.max_children = 8
pm.start_servers = 2
pm.min_spare_servers = 2
pm.max_spare_servers = 4
pm.max_requests = 500

Second, this is set to static. Use only if you have quite a lot of free ram left. (A few gbs)
Code:
[www]
listen = 127.0.0.1:9000
listen.allowed_clients = 127.0.0.1
user = php
group = php
pm = static
pm.process_idle_timeout = 3s
pm.max_children = 8
pm.start_servers = 8

I still highly recommend Varnish if you use a heavy php site that doesn't update like every minute.

I've emailed with the top command output using these settings. Not helping.
#14
Was it like this for a while or did it start using a huge amount of resources after you installed any scripts or changed any settings or configurations? I think it's kinda strange none of these configurations are working for you right now. Do you remember doing any changes to the configs or installing a script? It could be simply an error that was done by accident or there could be something conflicting with one another. I was going to post a configuration of mine but they are quite similar to the ones already posted on this thread.

How many requests do you get usually?
#15
@Jake I'm highly sure that this is because of very old software. Also buggy php scripts does this.
#16
(2016-09-01, 10:52:08 am)Jake Wrote:  Was it like this for a while or did it start using a huge amount of resources after you installed any scripts or changed any settings or configurations? I think it's kinda strange none of these configurations are working for you right now. Do you remember doing any changes to the configs or installing a script? It could be simply an error that was done by accident or there could be something conflicting with one another. I was going to post a configuration of mine but they are quite similar to the ones already posted on this thread.

How many requests do you get usually?

It's when we get more than 150 realtime users approx. Right now I'm using Cloudflare Cache everything rule to bypass server load.
#17
(2016-09-01, 10:41:47 pm)situnrocks Wrote:  It's when we get more than 150 realtime users approx. Right now I'm using Cloudflare Cache everything rule to bypass server load.

Make a dir called ngx_cache in /tmp

Terminal

mkdir /tmp/ngx_cache


Add this to your nginx.conf
Code:
fastcgi_cache_path /tmp/ngx_cache levels=1:2 keys_zone=ngxcache:1024mb;
fastcgi_cache_key "$scheme$request_method$host$request_uri";

The. add this under location .php in your vhost config
Code:
fastcgi_cache ngxcache;
fastcgi_cache_valid 200 10m;

This enables caching of php pages in nginx. (Better not confuse you with the addition of varnish I guess. Let's just use nginx's cahing)
This should reduce your load. You can increase 10m in fastcgi_cache_valid if your load doesn't decrease much. It will keep caching the pages for longer.




Users browsing this thread: 2 Guest(s)