Cloudflare Redirect loop
#1
I added cloudflare to hide my ip.
DNS Turned on my ip was not showing in cmd etc.
but my website went to redirect loop
The ssl from Cloudflare was on and lets encrypt was on Will it cause prblem?
 PiratesHosting Cheap Gameserver, Web Hosting, Reseller Hosting
█ Premium Gameserver, Shared, Reseller and VPS hosting Performance Solutions.
█ PiratesHosting Cheap Gameservers, Web Hosting, Reseller Hosting, Master Reseller
#2
Yes, that will cause problems. One thing I did to fix that was to install the cloudflare ssl fix wordpress plugin. Are you using WordPress, or just standalone html?

Anyways, you may always turn off Cloudflare's ssl to use Let's Encrypt, or the other way around. If you're using cloudflare's ssl and cpanel, be sure to setup a page rule for your cpanel web address, as it disables the css from loading.
Tall image removed by mod.
Wordpress Web Design, Wordpress News
#3
@arsalahmed786, do you have SSL redirects on? You cannot have auto-redirects for SSL with CloudFlare SSL enabled.

Like @Lux said, disable either one, and it should work.
My website: https://dawgy.pw
#4
If you still want to hide your IP address, then you should disable Let's Encrypt.

You just need to make sure you have added page rule of "Always use HTTPS" that lets Cloudflare to redirect all your http traffic to https.
#5
You'll have to add a page rule to disable always-on SSL for the location of the LE script, or the always-on SSL could cause issues. Shouldn't be causing the redirect loop though
Giveaway Manager, FreeVPS Directory and Discussion

Also a big fan of Anime, see my poor taste here.
#6
Why use Let's Encrypt for secure transmission of data between CF and your server? A self-signed certificate might be easier and do the job as well?
natcp-verify-token-20285
#7
@Rick
Let's encrypt is an real certificate authority that lets you get a trusted certificate automatically within the shell.
The reason to use them instead of using self signed certificates is that there will be a trusted party which will be able to verify your certificate with your user and the user will not have to add an exception in their browser for a new untrusted certificate.
There are much more advantages of using a real certificate authority than self signed, you can read about it off the web.
#8
what type cloudflare account do you have? if it's free, you can't use your own ssl or other ssl provider with their service
you should remove your ssl and use the ssl by cloudflare instead
and trying not use the SSL Strict and disable HSTS setting, mostly I have this problem when setup new website with cloudflare ssl
you can enable that setting again after you have working website.
#9
(2017-04-21, 4:18:06 am)deathbat6661 Wrote:  what type cloudflare account do you have? if it's free, you can't use your own ssl or other ssl provider with their service
you should remove your ssl and use the ssl by cloudflare instead
and trying not use the SSL Strict and disable HSTS setting, mostly I have this problem when setup new website with cloudflare ssl
you can enable that setting again after you have working website.

What are you saying? If you disable CloudFlare, it defeats the whole purpose of what the OP was trying to accomplish.

(that's why some members said to disable LE)
My website: https://dawgy.pw
#10
Well I got the same issue, it took me while to fix that in .htaccess I used {HTTP:X-Forwarded-Proto} instead of {HTTP_HOST}




Users browsing this thread: 1 Guest(s)