Gameserver keep crashing...
#1
Hello,
I have started observing that my server crashes now days a nice number of times..
when I tried to look in the logs of the gamesever,It gave me this output(during crashing):
http://pastebin.com/D6AuqYm2

any Idea why It might crashing?
The Gameserver is Halo which I am currently running on debian 8 with help of wine..
The Wine Version is 1.6.2
[Image: statimg.php]

[Image: img.php?userid=17802]

My Repo: Flow Theme - Flat Theme - Password Generator - Obsidian Theme
Spoiler: show
VPS2
SPEED TEST

[Image: 4571275887.png]

VPS9
SPEED TEST

[Image: 5393259505.png]
backup - http://puu.sh/oCtEe/db3314e03d.gif
For using the above Postcounter simply copy its link and replace the userid with your once.
if you have /30 posts count slot then just add &vps2 at the last of your postcounter url.
#2
Which WINE version? The 3 year old version from the official Debian repository or the one from the official website?

vitamin Wrote:In short - two or more threads are deadlocked. Most likely one of them crashed holding system critical section(s). ...

Likely to be an issue form the game server itself. Try updating WINE first. If that doesn't do it. Then I'd suggest trying to get support through official channels because you'll have a higher chance of getting a help there.
#3
@"S.L.C" OP mentioned re is running version 1.6.2.

@HMR it appears at first glance that OpenGL / libGL is not installed.

It appears it be a WINE problem indeed.

Please run these commands as root (Debian Jessie)

Code:
sudo dpkg --add-architecture i386
wget https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
echo "deb https://dl.winehq.org/wine-builds/debian/ jessie main" > /etc/apt/sources.list.d/wine.list
apt update
apt install wine
#4
(2017-02-15, 11:13:30 pm)MichaelW Wrote:  @"S.L.C" OP mentioned re is running version 1.6.2.

@HMR it appears at first glance that OpenGL / libGL is not installed.

It appears it be a WINE problem indeed.

Please run these commands as root (Debian Jessie)

Code:
sudo dpkg --add-architecture i386
wget https://dl.winehq.org/wine-builds/Release.key
sudo apt-key add Release.key
echo "deb https://dl.winehq.org/wine-builds/debian/ jessie main" > /etc/apt/sources.list.d/wine.list
apt update
apt install wine
And here is its output:

Terminal

root@hmrvps:~# sudo dpkg --add-architecture i386
root@hmrvps:~# wget https://dl.winehq.org/wine-builds/Release.key
converted 'https://dl.winehq.org/wine-builds/Release.key' (ANSI_X3.4-1968) -> 'https://dl.winehq.org/wine-builds/Release.key' (UTF-8)
--2017-02-15 08Happywide1:04-- https://dl.winehq.org/wine-builds/Release.key
Resolving dl.winehq.org (dl.winehq.org)... 151.101.64.69, 151.101.128.69, 151.101.192.69, ...
Connecting to dl.winehq.org (dl.winehq.org)|151.101.64.69|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3140 (3.1K) [application/pgp-keys]
Saving to: 'Release.key'

Release.key 100%[======================================================================>] 3.07K --.-KB/s in 0s

2017-02-15 08Happywide1:04 (53.0 MB/s) - 'Release.key' saved [3140/3140]

root@hmrvps:~# sudo apt-key add Release.key
OK
root@hmrvps:~# echo "deb https://dl.winehq.org/wine-builds/debian/ jessie main" > /etc/apt/sources.list.d/wine.list
root@hmrvps:~# apt update
Hit http://security.debian.org jessie/updates InRelease
Ign http://ftp.debian.org jessie InRelease
Hit http://ftp.debian.org jessie-updates InRelease
Hit http://security.debian.org jessie/updates/main amd64 Packages
Hit http://ftp.debian.org jessie Release.gpg
Hit https://deb.nodesource.com jessie InRelease
Get:1 https://dl.winehq.org jessie InRelease [2507 B]
Hit http://security.debian.org jessie/updates/contrib amd64 Packages
Hit http://security.debian.org jessie/updates/non-free amd64 Packages
Hit http://security.debian.org jessie/updates/main i386 Packages
Hit http://security.debian.org jessie/updates/contrib i386 Packages
Hit http://security.debian.org jessie/updates/non-free i386 Packages
Hit http://security.debian.org jessie/updates/contrib Translation-en
Hit http://security.debian.org jessie/updates/main Translation-en
Hit http://security.debian.org jessie/updates/non-free Translation-en
Get:2 http://ftp.debian.org jessie-updates/main amd64 Packages/DiffIndex [6916 B]
Hit https://deb.nodesource.com jessie/main Sources
Hit https://deb.nodesource.com jessie/main amd64 Packages
Hit https://deb.nodesource.com jessie/main i386 Packages
GetHappywide https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:4 https://dl.winehq.org jessie/main amd64 Packages [2938 B]
Hit http://ftp.debian.org jessie-updates/contrib amd64 Packages
Get:5 http://ftp.debian.org jessie-updates/non-free amd64 Packages/DiffIndex [736 B]
Get:6 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:7 http://ftp.debian.org jessie-updates/main i386 Packages/DiffIndex [6916 B]
Get:8 https://dl.winehq.org jessie/main i386 Packages [2919 B]
Get:9 https://dl.winehq.org jessie/main Translation-en [258 B]
Get:10 https://dl.winehq.org jessie/main Translation-en [258 B]
Get:11 https://dl.winehq.org jessie/main Translation-en [258 B]
Get:12 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:13 https://dl.winehq.org jessie/main Translation-en [258 B]
Get:14 https://dl.winehq.org jessie/main Translation-en [258 B]
Ign https://dl.winehq.org jessie/main Translation-en
Get:15 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:16 https://deb.nodesource.com jessie/main Translation-en [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en
Hit http://ftp.debian.org jessie-updates/contrib i386 Packages
Get:17 http://ftp.debian.org jessie-updates/non-free i386 Packages/DiffIndex [736 B]
Hit http://ftp.debian.org jessie-updates/contrib Translation-en
Get:18 http://ftp.debian.org jessie-updates/main Translation-en/DiffIndex [2704 B]
Get:19 http://ftp.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B]
Hit http://ftp.debian.org jessie Release
Hit http://ftp.debian.org jessie/main amd64 Packages
Hit http://ftp.debian.org jessie/contrib amd64 Packages
Hit http://ftp.debian.org jessie/non-free amd64 Packages
Hit http://ftp.debian.org jessie/main i386 Packages
Hit http://ftp.debian.org jessie/contrib i386 Packages
Hit http://ftp.debian.org jessie/non-free i386 Packages
Hit http://ftp.debian.org jessie/contrib Translation-en
Hit http://ftp.debian.org jessie/main Translation-en
Hit http://ftp.debian.org jessie/non-free Translation-en
Fetched 27.1 kB in 2s (12.6 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
127 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@hmrvps:~# apt install wine
Reading package lists... Done
Building dependency tree
Reading state information... Done
wine is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 127 not upgraded.
root@hmrvps:~#

[Image: statimg.php]

[Image: img.php?userid=17802]

My Repo: Flow Theme - Flat Theme - Password Generator - Obsidian Theme
Spoiler: show
VPS2
SPEED TEST

[Image: 4571275887.png]

VPS9
SPEED TEST

[Image: 5393259505.png]
backup - http://puu.sh/oCtEe/db3314e03d.gif
For using the above Postcounter simply copy its link and replace the userid with your once.
if you have /30 posts count slot then just add &vps2 at the last of your postcounter url.
#5
(2017-02-15, 11:13:30 pm)MichaelW Wrote:  @"S.L.C" OP mentioned re is running version 1.6.2.

Wasn't there when I replied. Otherwise I wouldn't have asked that question.


Also, you should've told him the link to the official page instead of copying it here and risking of leaving outdated information for future visitors. And also because you seem to have missed the final detail of the installation:

[Image: Untitled.png]

Which is why you're still trying to install the same old version.
#6
Ok this time the installation started, but looks like the version is still same:

Terminal

root@hmrvps:~# wine --version
wine-1.6.2
root@hmrvps:

[Image: statimg.php]

[Image: img.php?userid=17802]

My Repo: Flow Theme - Flat Theme - Password Generator - Obsidian Theme
Spoiler: show
VPS2
SPEED TEST

[Image: 4571275887.png]

VPS9
SPEED TEST

[Image: 5393259505.png]
backup - http://puu.sh/oCtEe/db3314e03d.gif
For using the above Postcounter simply copy its link and replace the userid with your once.
if you have /30 posts count slot then just add &vps2 at the last of your postcounter url.
#7
First try, purging the old version:

Code:
sudo apt-get purge wine
sudo apt-get autoremove

Then, I believe you've done these steps:

Code:
sudo dpkg --add-architecture i386
wget -qO https://dl.winehq.org/wine-builds/Release.key | sudo apt-key add -

But I think you added the wrong distro. A lot of the information from the previous tutorial seems to be incorrect. Edit the file /etc/apt/sources.list and remove the old repositiory you added:

Code:
deb https://dl.winehq.org/wine-builds/debian/ jessie main

And add the following for the stable version:
Code:
deb https://dl.winehq.org/wine-builds/debian/ debian-jessie-staging main

Or this one for the development version:
Code:
deb https://dl.winehq.org/wine-builds/debian/ debian-jessie-development main

Once you've added those. Save the file changes and run a:
Code:
sudo apt-get update

And now you may proceed to installing the stable version:
Code:
sudo apt-get install --install-recommends winehq-staging

Or the development version:
Code:
sudo apt-get install --install-recommends winehq-devel

You should've followed the official tutorial from the first post.
#8
@S.L.C.
Tried that and here is the output after apt-update onwards:
http://pastebin.com/5Wu46gAR

Terminal

root@hmrvps:~# wine --version
wine-2.1 (Staging)
root@hmrvps:~#


Don't you think something is not right with that update output ?

And now when I start my gameserver, then inbetween this error shows:

Terminal

err:winsock:interface_bind Failed to bind to interface, receiving broadcast packets will not work on socket 0104.
err:winsock:interface_bind Failed to bind to interface, receiving broadcast packets will not work on socket 0108.


Would be tempering me in future ?
[Image: statimg.php]

[Image: img.php?userid=17802]

My Repo: Flow Theme - Flat Theme - Password Generator - Obsidian Theme
Spoiler: show
VPS2
SPEED TEST

[Image: 4571275887.png]

VPS9
SPEED TEST

[Image: 5393259505.png]
backup - http://puu.sh/oCtEe/db3314e03d.gif
For using the above Postcounter simply copy its link and replace the userid with your once.
if you have /30 posts count slot then just add &vps2 at the last of your postcounter url.
#9
That's funny. You attempted to install the stable version which should be 2.0 and somehow you got the development version installed 2.1. For the update errors. I'm not sure I can do much. If there's something wrong with it then that should be a question for the official WINE community. Because it seems that the installation guide that they provided is not fully functional.

As for the second error that your server generated. I'm not entirely sure why. I don't use WINE or play Halo. And I'm pretty sure not a lot of people in here do so. I guess you'll have to try on the official channels and see if you can get better support in there.




Users browsing this thread: 1 Guest(s)