Myblogs.me - Post2Host Service
#11
@umarmalik
Your main concern should be the home page. That will be the page shown to majority of new users. Having a very slow homepage will deter users from using your site. (including me)

9MB is actually very large. Even major website homepages aren't big. Try limiting your media on your homepage.
[Image: img.php?v2=1&userid=14657&txt=1]
Want to use this image? 
Spoiler: show
1 VPS (Post counter image): https://7ob.pw/FreeVPS/img.php?userid={userid}
1 VPS (Post counter page): https://7ob.pw/FreeVPS/?userid={userid}
2 VPS (Post counter image): https://7ob.pw/FreeVPS/img.php?v2=1&userid={userid}
2 VPS (Post counter page): https://7ob.pw/FreeVPS/?v2=1&userid={userid}
Thanks to the FreeVPS Staff! Thanks also to FuzzyHosts & ZXPlay for their great VPS!
I don't like writing. expect only 1-2 sentences from me. My real join date is 2013-02-03 btw :p
Spoiler: show
FuzzyHosts (VPS 2)
http://tny.im/7Ol
BitAccel VPS (FreeDomain.Club)
http://tny.im/26w

Old VPS:
BoneVM VPS (Old VPS 8)
http://tny.im/26v
GalaxyHostPlus (VPS 9)
http://tny.im/7Oj

Mobile 3G (Morning Speed)
http://tny.im/7Ok
[Image: d.php]
#12
I think the problem with your home page is you have way too much content in that making it very heavy. 9MB is a massive among. I only checked from moblie I dont know how it looks from desktop. Move all package information to a separate page. Keep a link or banner on home page saying " Check our free vps package list here ". That will take a heavy load out of main page. Also people like to find information they want fast, rather than go through too much content.
#13
(2017-03-22, 4:46:20 am)umarmalik Wrote: Oh yeah, the size of main website is bit huge maybe that was the reason. But both the forum and website is hosting on the same host. I tested the forum only because our main concern is the forum.  Any suggestion that help me to fix the main website in speed section?  Smile

It's easy: reduce the size of the theme that you are using. Over 230 requests were made to your server (NameCheap?) when I first loaded it.

(reducing it can be as simple as reverting it to the original theme)

EDIT: Like Kyrie said, I was about to exit your site, when the loading bar inched a bit on Safari. That's when I hopped onto Chrome to see the network breakdown and do the Pingdom test.

EDIT #2: Even WS (not trying to advertise), and many popular websites like Google use PageSpeed.

It does a good job in condensing a lot of large files into a small, gzip'ed and m'initier file.

It reduced loading times dramatically when it was enabled.
I have VPS 18 (Hostigation) and 24 (HostDare).

#14
SSD VPS looks good as they are rarely found giving for free, same goes for the Windows VPS, anyways you must update your forum's theme, since light theme is liked by majority of the people.
#15
You should also be enforcing HTTPS on your login page/registration page, or even your entire site. I believe it increases your Google search rankings. Let's Encrypt is a great place to get a free SSL certificate.
-karatekidmonkey (https://codeco.pw)
Thanks to ZXPlay for my VPS!
Posts
#16
(2017-03-26, 5:34:30 am)karatekidmonkey Wrote: You should also be enforcing HTTPS on your login page/registration page, or even your entire site. I believe it increases your Google search rankings. Let's Encrypt is a great place to get a free SSL certificate.

True. Aside from that, as far as I know, Chrome will show some alert in case it detects a form without being on a secure (https) connection. This might scare people off, which is totally fine since you SHOULD definately use a secure connection, especially now when you can get SSL certificates for free (Let's Encrypt, as mentioned by karatekidmonkey)
Thanks to FreeVPS and Verelox for my VPS 8!
Also a big thanks to NoUptime.host for their great FREE VPS!
[Image: img.php?userid=20285]
#17
(2017-03-26, 8:15:39 pm)Rick Wrote: True. Aside from that, as far as I know, Chrome will show some alert in case it detects a form without being on a secure (https) connection. This might scare people off, which is totally fine since you SHOULD definately use a secure connection, especially now when you can get SSL certificates for free (Let's Encrypt, as mentioned by karatekidmonkey)

It was firefox I believe, there was an article on Ars Technica regarding it (I'm a chromium user and I don't get any warnings like that, but I have seen it happen on Firefox).
-karatekidmonkey (https://codeco.pw)
Thanks to ZXPlay for my VPS!
Posts




Users browsing this thread: 1 Guest(s)

Switch to mobile version

Sponsors: Ftpit - ZXPlay - GalaxyHostPlus - Verelox- HostUS - HostMada - Host4Fun - Evolution-Host - NodeBlade - HostDare - VPSMost


BitCoin donations: 1DQxbstaTb5SWk6QC2gFeQUTFR64JX4cEo