[SOLVED] Can't able to use https links @ wget
#1
Hello,
I had newly installed one of my VPSs with CentOS 6.
and looks like the wget of it isn't able to download files from https links.. and gives this Error:

Terminal

[test@test]# wget --no-check-certificate https://files.phpmyadmin.net/phpMyAdmin/...ish.tar.gz
--2017-06-16 10:21:04--  https://files.phpmyadmin.net/phpMyAdmin/...ish.tar.gz
Could not seed PRNG; consider using --random-file.
Disabling SSL due to encountered errors.


More info:

Terminal

[test@test]# wget --version
GNU Wget 1.12 built on linux-gnu.

+digest +ipv6 +nls +ntlm +opie +md5/openssl +https -gnutls +openssl
-iri

Wgetrc:
    /etc/wgetrc (system)
Locale: /usr/share/locale
Compile: gcc -DHAVE_CONFIG_H -DSYSTEM_WGETRC="/etc/wgetrc"
    -DLOCALEDIR="/usr/share/locale" -I. -I../lib -O2 -g -pipe -Wall
    -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
    --param=ssp-buffer-size=4 -m64 -mtune=generic -fno-strict-aliasing
Link: gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
    -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic
    -fno-strict-aliasing -Wl,-z,relro -lssl -lcrypto
    /usr/lib64/libssl.so /usr/lib64/libcrypto.so -ldl -lrt ftp-opie.o
    openssl.o http-ntlm.o gen-md5.o ../lib/libgnu.a

Copyright © 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
<http://www.gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Originally written by Hrvoje Niksic <hniksic@xemacs.org>.
Currently maintained by Micah Cowan <micah@cowan.name>.
Please send bug reports and questions to <bug-wget@gnu.org>.


[Image: statimg.php]

[Image: img.php?userid=17802]

My Repo: Flow Theme - Flat Theme - Password Generator - Obsidian Theme
Spoiler: show
VPS2
SPEED TEST

[Image: 4571275887.png]

VPS9
SPEED TEST

[Image: 5393259505.png]
backup - http://puu.sh/oCtEe/db3314e03d.gif
For using the above Postcounter simply copy its link and replace the userid with your once.
if you have /30 posts count slot then just add &vps2 at the last of your postcounter url.
#2
Try checking if you have openssl. If you have it, reinstall it.

Try using the flag --random-file as it says for now though.

EDIT:
Some useful links
https://help.directadmin.com/item.php?id=227
#3
(2017-06-17, 1:48:24 am)Conan Wrote: Try using the flag --random-file as it says for now though.

EDIT:
Some useful links
https://help.directadmin.com/item.php?id=227
Already tried but still same..

But looks like when I switch OS from CentOS( 64Bits) to CentOS( 32Bits).

then its working again..

Anyways thanks for the Help!
[Image: statimg.php]

[Image: img.php?userid=17802]

My Repo: Flow Theme - Flat Theme - Password Generator - Obsidian Theme
Spoiler: show
VPS2
SPEED TEST

[Image: 4571275887.png]

VPS9
SPEED TEST

[Image: 5393259505.png]
backup - http://puu.sh/oCtEe/db3314e03d.gif
For using the above Postcounter simply copy its link and replace the userid with your once.
if you have /30 posts count slot then just add &vps2 at the last of your postcounter url.
#4
@HMR switch back to the x64 bit and use this command:

Code:
yum install ca-certificates


[Image: img.php?userid=19870&txt=1]

Thanks to FREEVPS.us  for VPS 14
A huge shoutout to @F7N for the steller cPanel Hosting
Follow me on Mastodon
View me on IRC @SlashNET

[url=https://7ob.pw/FreeVPS/?userid=19870][/url]
#5
@MichaelW

Code:
--no-check-ceritificate

Was already on his cli arguments. So updating or installing ca-certs won't really help.

I think it's an OS issue though.

#6
OP has marked issue as solved. Thread is now closed.




Users browsing this thread: 1 Guest(s)

Switch to mobile version

Sponsors: Ftpit - ZXPlay - GalaxyHostPlus - Verelox- HostUS - Host4Fun - Evolution-Host - NodeBlade - HostDare - VPSMost


BitCoin donations: 1DQxbstaTb5SWk6QC2gFeQUTFR64JX4cEo