Odd cPanel experience - add on domain on root instead of in public_html
#1
Last night as I was trying to move my Websites out of VPS 27, I had a slight hickup with a new add on domain at a shared hosting account with cPanel.  Like I'm used to once I've added the domain to find it in the public_html folder.  But this domain was in root on the same level as public_html.  So I thought that must be a mistake and moved the domain to inside public_html.  Then when I tried the domain, it wouldn't connect.  I waited a few hours as I thought the new IPs still needed more time to resolve, but when I did a DNS Inspect check this morning found that it scored "A" for DNS.  DNS was OK.  Except the Website wouldn't connect.

I then deleted the add on domain, reinstalled it, and it once again created a root folder outside the public_html in file manager.  I then tested it, and the new domain worked perfect.  I've kept it there, but it's puzzling me.

Am I going dotty here?  Like I always thought anything for public has to go in the public_html folder.  All of my other Websites, including WordPress sites are in my public_html folder except for the new add on domain that insisted it wanted to be outside.  Did this happen with a recent WHM update perhaps that I'm unaware off?  Like add on domains are now created in root instead of in public_html?
#2
I'm not 100% sure on this, but I believe that this was a change that occurred in cPanel 66. I'd assume that it is a security measure so people can't access rootdomain.com/sub.rootdomain.com.
-karatekidmonkey (https://codeco.pw)
Thanks to ZXPlay for my VPS!
http://www.islc.eu.org/fvps/index.php?userid=17742

natcp-verify-token-17742


Recheck
#3
I have a shared hosting account and this was also the setup.
I don't complain as for me its clean, better and has advantage.
Especially if you have a lot of domains hosted on the same host.
Please excuse my English as this is not my native language.
Thank you Hostigation and FreeVPS for my VPS 18
FREE 250GBps DDoS Protection by HostingFuze Network | https://www.hostingfuze.net
natcp-verify-token-20223
#4
Agreed. I don't have any complaints either. I'm just puzzled. I have four other domains in the same hosting account and they are all under public_html. Like from the beginning of my Website experience we are used to always loading our Websites in public_html. This is something that must have happened recently. Tonight I loaded some more Websites that were previously in my VPS and they also were outside public_html. Must have been a cPanel update as I have the WHM on automatic updates.




Users browsing this thread: 2 Guest(s)

Switch to mobile version

Sponsors: Ftpit - ZXPlay - GalaxyHostPlus - Verelox- HostUS - HostMada - Host4Fun - Evolution-Host - NodeBlade - HostDare - VPSMost


BitCoin donations: 1DQxbstaTb5SWk6QC2gFeQUTFR64JX4cEo